Discourse Showing Blank Page After Rebuild / Upgrade


#1

Problem: Discourse forum shows blank page after rebuild / upgrade

Similar problems reported on official discourse meta:

  • when I try to access the URL the page is completely blank. The browser seems to connect because I can even view the certificate for the site, but the page is blank.
  • I tried upgrading to newer version from admin panel. After completion of the process the site is showing only blank page.
  • again blank page, nothing displaying the site.

Solution: Remove third party plugin from containers/app.yml and rebuild

Found solutions from official discourse meta:

  • This usually means your plugins are incompatible with the new version. Disable all third party plugins and rebuild. You can also check the browser console with f12 to see if the errors there tell you anything. To remove plugins edit /var/discourse/containers/app.yml file and remove your plugin related lines.
  • I tried removing adsense plugin and it worked!
  • Issue resolved. It was due to tagging plugin.